To view uptime history for your instance of Canvas, click here.

A subset of users are experiencing long load times or error messages when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Dec 08, 2020 - 11:36 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 08, 2020 - 11:26 MST
Investigating
A subset of users are experiencing long load times or error messages when accessing Canvas. Our DevOps team is currently investigating the issue, and we'll provide an update shortly.
Posted Dec 08, 2020 - 11:23 MST
This incident affected: Canvas (Canvas LMS).