To view uptime history for your instance of Canvas, click here.

Some users in our SYD region are experiencing 500 page errors and slow load times.
Incident Report for Instructure
Resolved
Our Devops team was able to identify and fix this issue. This incident has been resolved.
Posted Oct 21, 2020 - 18:24 MDT
Investigating
We are currently investigating this issue.
Posted Oct 21, 2020 - 18:19 MDT