To view uptime history for your instance of Canvas, click here.

A subset amount of users are experiencing long load times or page errors when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 23, 2021 - 10:13 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2021 - 10:07 MDT
Investigating
A subset amount of users are experiencing long load times or page errors when accessing Canvas. Our DevOps team are currently investigating this issue, and we'll provide an update shortly.
Posted Mar 23, 2021 - 10:03 MDT
This incident affected: Canvas (Canvas LMS).