To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or page time outs when accessing Canvas
Incident Report for Instructure
Resolved
Load times have remained in the acceptable ranges when accessing Canvas. Thank you for your patience while our team corrected this.
Posted Mar 23, 2020 - 11:53 MDT
Monitoring
Load times for the affected users have returned to normal. We will continue to monitor this and make sure that load times stay in the acceptable ranges.
Posted Mar 23, 2020 - 11:15 MDT
Identified
Our devops team was able to identify the cause of the load times and are actively working to implement a fix for these load times.
Posted Mar 23, 2020 - 09:05 MDT
Investigating
Some users are experiencing long load times and page errors when accessing Canvas. We are looking into this issue and will provide updates as they come.
Posted Mar 23, 2020 - 08:50 MDT
This incident affected: Canvas (Canvas LMS).