To view uptime history for your instance of Canvas, click here.

Small amount of users in IAD region may be getting page errors
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted May 16, 2022 - 08:13 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 16, 2022 - 08:00 MDT
Investigating
We are currently investigating this issue.
Posted May 16, 2022 - 07:49 MDT
This incident affected: Canvas (Canvas LMS).