To view uptime history for your instance of Canvas, click here.

Canvas imports failing
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 00:05 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 19, 2024 - 15:14 MST
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).