Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
This has been resolved.
Posted Mar 31, 2020 - 15:50 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 31, 2020 - 09:09 MDT
Investigating
We are currently investigating this issue.
Posted Mar 31, 2020 - 07:15 MDT