Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 27, 2020 - 12:04 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 27, 2020 - 11:53 MDT
Investigating
We are currently investigating this issue.
Posted Apr 27, 2020 - 11:47 MDT