To view uptime history for your instance of Canvas, click here.

Some users experiencing timeouts and page errors.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 27, 2020 - 00:27 MDT
Monitoring
Some users experienced timeouts and page errors when attempting to access Canvas. Our DevOps team has Identified and resolved the issue.
Posted Apr 27, 2020 - 00:10 MDT