To view uptime history for your instance of Canvas, click here.

A small amount of users maybe experiencing long load times when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 31, 2020 - 07:21 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 31, 2020 - 07:15 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 31, 2020 - 07:06 MDT
Investigating
We are currently investigating this issue.
Posted Aug 31, 2020 - 06:54 MDT
This incident affected: Canvas (Canvas).