To view uptime history for your instance of Canvas, click here.

Some user are experiencing long load times when accessing Canvas.
Incident Report for Instructure
Resolved
Canvas has resumed normal operations, and users are no longer experiencing long load times. We thank you for your patience.
Posted Jan 13, 2020 - 11:04 MST
Monitoring
Our DevOps team have implemented a fix, and it looks like users are experiencing normal load times. We'll monitor the situation closely for the next few minutes.
Posted Jan 13, 2020 - 10:59 MST
Investigating
Some users are experiencing long load times when accessing Canvas. Our DevOps team are currently investigating this issue, and we'll provide an update in a few minutes.
Posted Jan 13, 2020 - 10:48 MST
This incident affected: Canvas (Canvas LMS).