Some customers might experience low response times and page errors
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 06, 2020 - 10:59 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 06, 2020 - 09:40 MDT
Investigating
We are currently investigating this issue.
Posted Apr 06, 2020 - 09:22 MDT