To view uptime history for your instance of Canvas, click here.

Some users may run into slow load times or error messages when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jul 19, 2020 - 12:25 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 19, 2020 - 09:38 MDT
This incident affected: Canvas (Canvas, — Catalog, — Chat, — Collaboration, — Commons, — Conferences, — Document previewing, — Imports and exports, — Media tools, — Notifications, — Support: Phones/Chat, — Support: Webform/email, — ePortfolios, — Gauge).