To view uptime history for your instance of Canvas, click here.

A small subset of users are experiencing slowness or page timeout errors when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Oct 08, 2020 - 10:23 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2020 - 10:10 MDT
Investigating
A small subset of users are experiencing slowness or page timeout errors when accessing Canvas. Our DevOps teams is currently investigating this issue, and we'll provide a new update in a few minutes.
Posted Oct 08, 2020 - 10:05 MDT
This incident affected: Canvas (Canvas).