To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or page time outs when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Sep 28, 2020 - 10:00 MDT
Monitoring
Additional resources have been added to the affected areas. Errors and load times have improved however we will continue to monitor to ensure that it continues to load correctly.
Posted Sep 28, 2020 - 09:49 MDT
Identified
Our team has identified the cause of the load times and page errors, and are working to add more resources to correct this.
Posted Sep 28, 2020 - 09:36 MDT
Investigating
We are currently investigating slow load times and occasional page errors that some users are receiving when accessing Canvas.
Posted Sep 28, 2020 - 09:27 MDT
This incident affected: Canvas (Canvas LMS).