To view uptime history for your instance of Canvas, click here.

Some users may be seeing page errors when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 27, 2024 - 11:43 MDT
Update
We are continuing to monitor for any further issues.
Posted Aug 27, 2024 - 11:24 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 27, 2024 - 11:20 MDT
Investigating
We are currently investigating this issue.
Posted Aug 27, 2024 - 11:02 MDT
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).