To see historical uptime for Canvas and other services for a specific instance, click here.

Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 18, 2020 - 19:15 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2020 - 19:08 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 18, 2020 - 19:07 MDT
Investigating
We are currently investigating this issue.
Posted Mar 18, 2020 - 19:05 MDT