To view uptime history for your instance of Canvas, click here.

504 error and long load times for some users in the SYD Region

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Mar 02, 2025 - 19:13 MST

Update

Our engineering team is still investigating the cause of the slowness and page errors for our Canvas users.
Posted Mar 02, 2025 - 18:25 MST

Investigating

We are currently investigating this issue.
Posted Mar 02, 2025 - 16:18 MST
This incident affected: Canvas (Canvas LMS).