To view uptime history for your instance of Canvas, click here.

Long Load Times
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 07, 2022 - 07:31 MDT
Investigating
A small group of users are experiencing long load times or experiencing page errors in the IAD region
Posted Apr 07, 2022 - 07:12 MDT