To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or error messages when accessing Portfolium.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Oct 12, 2021 - 07:22 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 12, 2021 - 07:19 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 12, 2021 - 07:15 MDT
Investigating
We are currently investigating this issue.
Posted Oct 12, 2021 - 06:48 MDT
This incident affected: Portfolium (Website).