To view uptime history for your instance of Canvas, click here.

Studio requests taking longer
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 24, 2020 - 15:52 MDT
Monitoring
Our team has deployed a fix for the slow load times inside of Studio. We will monitor the fix to make sure it's working as intended.
Posted Aug 24, 2020 - 15:11 MDT
Investigating
Users making requests using the Studio tool in Canvas may experience a longer processing time. This is currently being investigated by our team.
Posted Aug 24, 2020 - 11:25 MDT
This incident affected: Canvas (— Media tools).