To view uptime history for your instance of Canvas, click here.

Admin Analytics and Intelligent Insight Reports May Not Load for Some Users
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 22, 2024 - 15:58 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 22, 2024 - 14:57 MDT
Identified
We have identified the cause of very slow data loads affecting Admin Analytics and Intelligent Insights.
Posted Aug 21, 2024 - 16:31 MDT
Update
We are continuing to investigate this issue.
Posted Aug 21, 2024 - 15:56 MDT
Update
We are continuing to investigate this issue.
Posted Aug 21, 2024 - 15:07 MDT
Update
We are continuing to investigate this issue.
Posted Aug 21, 2024 - 13:48 MDT
Investigating
We are currently investigating this issue.
Posted Aug 21, 2024 - 10:35 MDT
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1, us-west-2).