To view uptime history for your instance of Canvas, click here.

Some users may be receiving a 500 error messages or general Canvas slowness when attempting to access Canvas if they are hosted in our PDX region.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Dec 14, 2021 - 06:37 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 14, 2021 - 06:16 MST
Identified
After deploying the fix, we started experiencing another wave of errors, so we are working on identifying the reason behind these error messages.
Posted Dec 14, 2021 - 05:36 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 14, 2021 - 05:27 MST
Identified
We are receiving some additional reports about page errors. We are currently investigating this issue.
Posted Dec 14, 2021 - 04:32 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 14, 2021 - 04:19 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 14, 2021 - 04:13 MST
Investigating
We are currently investigating this issue.
Posted Dec 14, 2021 - 04:06 MST
This incident affected: Canvas (Canvas LMS).