To view uptime history for your instance of Canvas, click here.

Canvas users in the US may be experiencing Slowness
Incident Report for Instructure
Resolved
Or DevOps Team has identified and resolved the page load times for effected users. We apologize for any inconvenience caused.
Posted Feb 05, 2018 - 05:35 MST
Investigating
We are aware of slowness effecting a small portion of users in the US Central area. We apologize for the disruption to service and or Devops team are working on resolving the page page load times.
Posted Feb 05, 2018 - 05:09 MST