To view uptime history for your instance of Canvas, click here.

Slow load times or error messages when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jun 23, 2020 - 13:13 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2020 - 13:05 MDT
Investigating
we are currently looking into an issue where users are running into error messages or slow load times when accessing Canvas
Posted Jun 23, 2020 - 12:57 MDT
This incident affected: Canvas (Canvas LMS).