To view uptime history for your instance of Canvas, click here.

Some Users May Encounter Errors When Accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 07, 2024 - 18:20 MST
Monitoring
Some users may have encountered errors for a brief period. We have found the cause and a fix is in place. We are now monitoring the resolution.
Posted Mar 07, 2024 - 18:03 MST
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).