To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or error messages when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Nov 13, 2020 - 01:32 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2020 - 01:29 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 13, 2020 - 01:27 MST
Investigating
We are currently investigating this issue.
Posted Nov 13, 2020 - 01:20 MST
This incident affected: Canvas (Canvas LMS).