To view uptime history for your instance of Canvas, click here.

Page Errors When Accessing Canvas

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Feb 13, 2023 - 14:46 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2023 - 14:41 MST

Investigating

Some users may encounter "this page isn't working" errors when accessing Canvas.
Posted Feb 13, 2023 - 14:38 MST
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).