Slow load times or error messages when accessing Canvas
Incident Report for Instructure
Resolved
The incident has been resolved.
Posted Jun 07, 2020 - 15:48 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 07, 2020 - 15:43 MDT
Update
We are continuing to investigate this issue.
Posted Jun 07, 2020 - 15:30 MDT
Update
We are continuing to investigate this issue.
Posted Jun 07, 2020 - 15:14 MDT
Update
We are continuing to investigate this issue.
Posted Jun 07, 2020 - 15:01 MDT
Investigating
Some users are reporting slow load times or error messages when accessing Canvas. we are currently investigating this issue
Posted Jun 07, 2020 - 14:56 MDT
This incident affected: Canvas (Canvas).