To view uptime history for your instance of Canvas, click here.

Some Users May Be Experiencing Slowness Or 504 Errors
Incident Report for Instructure
Resolved
Our DevOps Team has identified and resolved this issue. Canvas has returned to normal operations.
Posted Jul 15, 2020 - 23:13 MDT
Update
We are continuing to investigate this issue.
Posted Jul 15, 2020 - 23:04 MDT
Update
We are continuing to investigate this issue.
Posted Jul 15, 2020 - 22:49 MDT
Investigating
Some users are seeing 504 Errors or slow loading times when attempting to access Canvas.
Posted Jul 15, 2020 - 22:33 MDT
This incident affected: Canvas (Canvas LMS).