To view uptime history for your instance of Canvas, click here.

Canvas Phone Support
Incident Report for Instructure
Resolved
We have worked with our phone provider (Sharpen) to resolve the behavior. Users should be able to contact Canvas support via phone without any issues.
Posted May 18, 2022 - 16:45 MDT
Investigating
Some users may have problems contacting Canvas via the phone support system. If you are not able to reach us via that method, we would recommend trying our chat or email support lines.
Posted May 18, 2022 - 16:19 MDT
This incident affected: Support Tools (Support: Phones/Chat).