To view uptime history for your instance of Canvas, click here.

Some users in Singapore region seeing slow page load times
Incident Report for Instructure
Resolved
The issue has been resolved, and users should be able to access Canvas as expected. Thank you so much for your patience.
Posted Oct 06, 2019 - 05:45 MDT
Monitoring
Our DevOps team were able to identify the issue and implement a fix, and it appears that Canvas pages are loading normally now. We'll monitor this situation closely for the next few minutes.
Posted Oct 06, 2019 - 05:36 MDT
Update
We are continuing to investigate this issue.
Posted Oct 06, 2019 - 05:34 MDT
Investigating
We are receiving reports that Canvas is experiencing longer than normal load times for some schools based in the Singapore AWS region. Our DevOps team is investigating this issue. We'll provide an update on this shortly.
Posted Oct 06, 2019 - 05:25 MDT