To view uptime history for your instance of Canvas, click here.

Slow load times or error messages when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jun 09, 2020 - 09:00 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 09, 2020 - 08:52 MDT
Investigating
Some of our North America users are running into longer than normal load times or error messages when attempting to access Canvas. We are currently investigating this issue.
Posted Jun 09, 2020 - 08:41 MDT
This incident affected: Canvas (Canvas LMS).