To view uptime history for your instance of Canvas, click here.

Some Canvas users are experiencing slow load times
Incident Report for Instructure
Resolved
The slow page behavior has now ceased, and Canvas is loading normally once again. Thank you so much for your continued patience.
Posted Apr 12, 2019 - 10:45 MDT
Monitoring
We're now seeing the long load times and page errors lowering back to expected levels within Canvas. We're continuing to monitor to ensure there's not further issues, or reoccurrences. We apologize again for this situation.
Posted Apr 12, 2019 - 10:28 MDT
Update
We are continuing to investigate the cause of slow load times within Canvas. Unfortunately the load times have increased since the previous update, and some users are now experiencing time-out errors when trying to access Canvas. We will continue to work on getting these errors and slow load times remedied, we sincerely apologize for the inconvenience and appreciate your patience.
Posted Apr 12, 2019 - 10:02 MDT
Investigating
Some users are experiencing longer load times than normal. Our engineering team is investigating the cause of the slow response times within Canvas, and we will post another update shortly. We appreciate your patience.
Posted Apr 12, 2019 - 09:45 MDT
This incident affected: Canvas (Canvas LMS).