To view uptime history for your instance of Canvas, click here.

Docviewer Page Errors - IAD Region as well as some users on the PDX Region
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 28, 2022 - 12:51 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2022 - 11:34 MDT
Identified
We believe we have identified the issue and are rolling out a fix.
Posted Apr 28, 2022 - 11:16 MDT
Update
We are continuing to investigate this issue.
Posted Apr 28, 2022 - 10:38 MDT
Investigating
We are currently investigating users experiencing - (Service is currently unavailable. Try again later)
Posted Apr 28, 2022 - 10:37 MDT
This incident affected: Canvas (Canvas).