To view uptime history for your instance of Canvas, click here.

Some users are experiencing 504 Errors while on Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jun 05, 2020 - 22:56 MDT
Update
We are continuing to investigate this issue.
Posted Jun 05, 2020 - 22:09 MDT
Update
We are continuing to investigate this issue.
Posted Jun 05, 2020 - 20:28 MDT
Update
We are continuing to investigate this issue.
Posted Jun 05, 2020 - 20:01 MDT
Update
We are continuing to investigate this issue.
Posted Jun 05, 2020 - 19:27 MDT
Update
We are continuing to investigate this issue.
Posted Jun 05, 2020 - 18:59 MDT
Investigating
We are currently investigating this issue.
Posted Jun 05, 2020 - 18:39 MDT
This incident affected: Canvas (Canvas LMS).