To view uptime history for your instance of Canvas, click here.

A small amount of users are experiencing long load times when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 18, 2020 - 09:57 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 18, 2020 - 09:42 MDT
Investigating
A small amount of users are experiencing long load times or error messages when accessing Canvas. Our DevOps team is currently investigating the issue, and we'll provide an update shortly.
Posted Aug 18, 2020 - 09:39 MDT
This incident affected: Canvas (Canvas LMS).