To view uptime history for your instance of Canvas, click here.

Canvas Support Phones System
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted May 18, 2020 - 20:24 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 18, 2020 - 15:25 MDT
Identified
The phone provider for Canvas Support is currently experiencing technical problems. Due to this fact reaching Canvas Support via phone may take longer than normal. You are still able to contact Canvas Support via our chat tool, email, and the help menu.
Posted May 18, 2020 - 14:40 MDT
Investigating
The phone provider for Canvas Support is currently experiencing technical problems. Due to this fact reaching Canvas Support via phone may take longer than normal. You are still able to contact Canvas Support via our chat tool, email, and the help menu.
Posted May 18, 2020 - 14:27 MDT
This incident affected: Support Tools (Support: Phones/Chat).