To view uptime history for your instance of Canvas, click here.

A small amount of users are experiencing long load times or error messages when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 01, 2021 - 02:47 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2021 - 02:45 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 01, 2021 - 02:44 MDT
Investigating
We are currently investigating this issue.
Posted Apr 01, 2021 - 02:42 MDT
This incident affected: Canvas (Canvas LMS).