To view uptime history for your instance of Canvas, click here.

Some videos in Studio may fail to load for users
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Sep 18, 2023 - 14:29 MDT
Investigating
We are currently investigating this issue.
Posted Sep 18, 2023 - 13:23 MDT
This incident affected: Canvas (Canvas Studio).