To view uptime history for your instance of Canvas, click here.

Some users may experience slow load times when accessing LTI Usage in Intelligent Insights
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Feb 14, 2025 - 03:00 MST
Investigating
We are currently investigating this issue.
Posted Feb 13, 2025 - 14:25 MST
This incident affected: Impact.