To view uptime history for your instance of Canvas, click here.

Some users are seeing errors while accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jun 14, 2020 - 18:48 MDT
Investigating
Some users are seeing errors while accessing Canvas. We are investigating this issue.
Posted Jun 14, 2020 - 18:44 MDT
This incident affected: Canvas (Canvas LMS).