To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or page time outs when accessing Canvas
Incident Report for Instructure
Resolved
Load times have been restored to normal.
Posted Oct 07, 2020 - 11:58 MDT
Monitoring
Load times have returned to normal for the affected users. We will continue to monitor to ensure that the load times have stabilized.
Posted Oct 07, 2020 - 11:45 MDT
Investigating
A small group of users are experiencing slow load times or page errors when accessing Canvas. Our team is actively investigating this to improve load times.
Posted Oct 07, 2020 - 11:39 MDT
This incident affected: Canvas (Canvas LMS).