To view uptime history for your instance of Canvas, click here.

A very small group of users are experiencing long load times or page time outs when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Feb 05, 2021 - 19:23 MST
Update
We are continuing to investigate this issue.
Posted Feb 05, 2021 - 19:15 MST
Investigating
We are currently investigating the issue.
Posted Feb 05, 2021 - 19:05 MST