To view uptime history for your instance of Canvas, click here.

Slow load times or error messages when accessing Canvas for some users
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jul 16, 2020 - 14:40 MDT
Monitoring
Our DevOps team have implemented a fix and we are monitoring the results.
Posted Jul 16, 2020 - 14:26 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 16, 2020 - 14:16 MDT
Identified
We're still seeing the small subset of users intermittently experience some slowness, and our team is currently working to resolve this. We'll provide another update shortly.
Posted Jul 16, 2020 - 13:57 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2020 - 13:38 MDT
Update
We are continuing to investigate this issue.
Posted Jul 16, 2020 - 13:33 MDT
Investigating
A small subset of Canvas users are experiencing slow load times or error messages when accessing Canvas. We're currently investigating the issue, and will provide an update shortly.
Posted Jul 16, 2020 - 13:18 MDT
This incident affected: Canvas (Canvas LMS).