To view uptime history for your instance of Canvas, click here.

Resolved - A Small Set of Users may not have been able to Access Canvas
Incident Report for Instructure
Resolved
Between 8:05 AM MDT and 8:15 AM MDT a small set of users may not have been able to access Canvas.
Posted Jun 13, 2024 - 08:00 MDT