To view uptime history for your instance of Canvas, click here.

Users May Encounter Long Load Times When Previewing Files in Docviewer
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 14:38 MDT
Update
We are continuing to investigate this issue.
Posted Sep 26, 2024 - 14:12 MDT
Investigating
We are currently investigating this issue.
Posted Sep 26, 2024 - 14:08 MDT
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).