To view uptime history for your instance of Canvas, click here.

Reports of long load times or page time outs when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 09:15 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2020 - 09:11 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 15, 2020 - 09:08 MDT
Investigating
We are currently investigating this issue.
Posted Oct 15, 2020 - 09:05 MDT
This incident affected: Canvas (Canvas).