To view uptime history for your instance of Canvas, click here.

A small amount of users are experiencing long load times or page errors when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 05:41 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2021 - 05:38 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 25, 2021 - 05:35 MST
This incident affected: Canvas (Canvas).