To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or page time outs when accessing Canvas
Incident Report for Instructure
Resolved
The load times that were impacting some users have returned to normal. We appreciate your patience while our team looked into this.
Posted Mar 02, 2020 - 05:43 MST
Monitoring
Load times have returned to normal. We will continue to monitor the situation to ensure that load times stay in the acceptable ranges.
Posted Mar 02, 2020 - 05:29 MST
Identified
Our DevOps team has reviewed the necessary resources and all pending requests have been cleared. Load times are returning to normal.
Posted Mar 02, 2020 - 05:27 MST
Investigating
Some users are experiencing long load times or page time outs when accessing Canvas. Our DevOps team is aware and currently investigating the issue.
Posted Mar 02, 2020 - 05:12 MST
This incident affected: Canvas (Canvas LMS).